Hay un conjunto de órdenes que permiten configurar las interfaces de router, y las órdenes son diferentes según el tipo de interfaces. Existen comandos diferentes para interfaces de redes inalámbricas o interfaces de redes conectadas por el puerto en serie.

Interfaces de red Ethernet (con cable)

Para configurar las direcciones IP de cualquier dispositivo se debe de acceder en modo global al router. A continuación cada una de las interfaces se tienen que activar y configurar. Hay un modo de configuración de interfaz donde se configurará la dirección IP y demás información.

Finalmente si fuera necesario, se puede activar la interfaz una vez se ha asignado una dirección IP. Vamos a ver como se debería de configurar.

Tendremos dos interfaces, en este caso dos FastEthernet con la siguiente configuración:

Interfaz IP Máscara
FasthEthernet0/0 192.168.1.1 255.255.255.0
FasthEthernet0/1 80.1.1.1 255.0.0.0

La primera configuración será al FastEthernet0/0:

barcelona#configure terminal 
barcelona(config)#interface fastEthernet0/0
barcelona(config-if)#description Conexion a Barcelona
barcelona(config-if)#ip address 192.168.1.1 255.255.255.0
barcelona(config-if)#no shutdown
💡
Es necesario activar la interfaz una vez asignada la dirección, esto se hace con el comando no shutdown. Si se desea desactivar una interfaz sólo se debe ejecutar el comando shutdown.

Y la segunda configuración será el FastEthernet0/1:

barcelona(config-if)#exit
barcelona(config)#interface fastEthernet 0/1                    
barcelona(config-if)#description Conexion madrid
barcelona(config-if)#ip address 80.1.1.1 255.0.0.0 
barcelona(config-if)#no shutdown

A continuación se puede ver la ejecución del comando show running-config, que muestra toda la configuración que hemos realizado:

barcelona#show running-config 
Building configuration...

Current configuration : 1238 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname barcelona
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$z1aq$xDhBWhwprP5dII5l6BJwc0
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!         
multilink bundle-name authenticated
!            
!         
archive   
 log config
  hidekeys        
!         
ip tcp synwait-time 5
!                 
!         
interface FastEthernet0/0
 description Conexion a Barcelona
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 description conexion madrid
 ip address 80.1.1.1 255.0.0.0
 duplex auto
 speed auto
!         
interface FastEthernet1/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet2/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
!         
no ip http server
no ip http secure-server
ip forward-protocol nd
!         
!         
!         
no cdp log mismatch duplex
!      
!         
control-plane
!           
banner motd ^CRouter Barcelona.local^C
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 password 123qweasd
 logging synchronous
 login    
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login    
!         
!         
end 

Para acabar, guardaremos la configuración con el siguiente comando:

barcelona#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]

De esta forma, cuando reiniciemos el router, la configuración guardada cargará automáticamente y ya tendremos las interfaces configuradas.

Haz que cada palabra cuente: tu donación nos inspira a seguir creando contenido. Accede al apartado de Donación para hacer tu aportación